Choregraphe 2.8.7 3D view keeps crashing

Posted 7 months ago by Johann Petrak

Post a topic
Un Answered
Johann Petrak

Running Choregraphe 2.8.7 on Ubuntu 22.04 with a Nvidia graphics card.

This worked fine for a while, no Choregraphe shows that the 3D is crashing on startup every time I run it.
Same happens with previous versions of Choregraph (tested

Working with this software is incredibly frustrating, web pages keep moving, when trying to find information one often finds outdated documentation, the API documentation is extremely lacking.
It seems to be impossible to get support easily either.
How to figure out what is wrong, how to correct this problem, how to submit a bug report for Choregraphe?

PS: even this forum is badly made, e.g. the even after logging in one gets annoyed with an I am not a robot visual challenge which is embedded in a tiny Iframe so one cannot even see all of the image to choose from at the same time!

0 Votes


Sorted by

Johann Petrak posted 7 months ago

Thanks - yes, I actually forgot that there was a problem with libz as well, I solved it in a similar way by copying into the choregraphe lib dir.

0 Votes


Lukas Brandt posted 7 months ago

Hey Johann,

I am not part of the Support Team, but in my case to make Choregraphe even run on my System (Ubuntu), I needed to do some post installation steps. Maybe you can try them if you haven't already:

Post Installation Steps Choregraphe 2.8 Linux:

  • Navigate to your Choregraphe lib folder:
  • cd /opt/Softbank\ Robotics/Choregraphe\ Suite\ 2.8/lib/

  • Back Up the old Library
  • sudo mv

  • And relink them with the System ones
  • sudo ln -s /usr/lib/x86_64-linux-gnu/

  • Start Choregraphe and check if your problems got fixed.

0 Votes


Johann Petrak posted 7 months ago

Is anyone from support actually ever attending to these forums?

0 Votes


Johann Petrak posted 7 months ago

OK, found out these things:

* environment variable QI_SDK_PREFIX must not be set (wrongly)

* removing all the config files from older versions in .config may help:

   * "Softbank Robotics", "naoqi", "qimessaging", "choregraphe", "Aldebaran Robotics"

After this, the crash disappeared and the 3D display worked

0 Votes

Login or Sign up to post a comment